Ergebnis 1 bis 3 von 3
  1. #1
    Kunde
    Registriert seit
    22.05.2018
    Beiträge
    1

    HTTPS-Weiterleitung iPad

    Hallo liebes Forum,

    ich habe für meinen Bruder ein AlphaSSL-Zertifikat gebucht. Scheinbar ist die Website nun sicher erreichbar, allerdings funktioniert die Weiterleitung auf HTTPS auf meinem iPad nicht. In der htaccess steht:

    Code:
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{HTTP_HOST} ^websitename.com
      RewriteRule ^(.*)$ https://www.websitename.com/$1 [r=301,L]
    </IfModule>
    websitename dient hier als Platzhalter. Wenn ich die Website ohne "www" aufrufe, klappt die Weiterleitung. Mit "www" funktioniert es nicht. Auf den anderen Geräten geht alles.

    Woran kann das liegen? Muss ich zusätzlich noch etwas einstellen? Oder etwas erweitern?

    Ein Kumpel von mir hat es gestestet. Bei ihm funktioniert alles.

    Über eine Antwort freue ich mich.

    Herzlichen Dank
    Konstantin

  2. #2
    Communityservice Avatar von Nils Dornblut
    Registriert seit
    15.10.2000
    Beiträge
    44.173

    AW: HTTPS-Weiterleitung iPad

    Hallo Konstantin,

    wenn es an einer Stelle funktioniert und mit einem anderen Browser nicht, liegt es meist bei htaccess eher am Cache. Hier finden sie sonst diverse Fälle und Vorschläge zum Thema Weiterleitung auf https:

    https://www.df.eu/forum/threads/8231...l=1#post528353

    Mit freundlichen Grüßen

    Nils Dornblut
    Communityservice
    __________________
    Blog - Facebook - Twitter
    Communitybetreiber: domainfactory GmbH
    Impressum / Pflichtangaben

  3. #3
    Forenexperte² (Reseller) Avatar von Enigma
    Registriert seit
    20.07.2001
    Beiträge
    18.461

    AW: HTTPS-Weiterleitung iPad

    Zitat Zitat von Konsti84 Beitrag anzeigen
    ich habe für meinen Bruder ein AlphaSSL-Zertifikat gebucht. Scheinbar ist die Website nun sicher erreichbar, allerdings funktioniert die Weiterleitung auf HTTPS auf meinem iPad nicht. In der htaccess steht:

    Code:
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{HTTP_HOST} ^websitename.com
      RewriteRule ^(.*)$ https://www.websitename.com/$1 [r=301,L]
    </IfModule>
    websitename dient hier als Platzhalter. Wenn ich die Website ohne "www" aufrufe, klappt die Weiterleitung. Mit "www" funktioniert es nicht. Auf den anderen Geräten geht alles.

    Woran kann das liegen? Muss ich zusätzlich noch etwas einstellen? Oder etwas erweitern?

    Ein Kumpel von mir hat es gestestet. Bei ihm funktioniert alles.
    Dass es anderswo funktioniert, ist extrem eigenartig. Deine .htaccess-Regel besagt: Wenn der Host "websitename.com" lautet (also explizit ohne "www."!), dann leite um zu https://www.websitename.com. Eine Umleitung http://www.websitename.com => https://www.websitename.com gibt es in der .htaccess nicht.

    Korrekt könnte das so aussehen:

    Code:
    <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteBase /
    
        RewriteCond %{HTTPS} !=On [NC,OR]
        RewriteCond %{HTTP_HOST} !=www.websitename.com [NC]
        RewriteRule ^(.*)$ https://www.websitename.com/$1 [R=301,L]
    </IfModule>
    Die RewriteBase wird hierfür nicht benötigt, ihr Fehlen führt aber häufig zu anderen Problemen, weshalb ich sie hier mit aufgeführt habe.

    Gruß
    Jan
    Two hours of trial and error can save ten minutes of manual reading.

Ähnliche Themen

  1. htaccess Weiterleitung https
    Von TimoVB im Forum htaccess
    Antworten: 12
    Letzter Beitrag: 16.05.2018, 18:56
  2. Weiterleitung auf https - ist das so richtig
    Von MissVip im Forum htaccess
    Antworten: 2
    Letzter Beitrag: 14.05.2018, 22:14
  3. 301 Weiterleitung bei https
    Von GrafFoto im Forum htaccess
    Antworten: 3
    Letzter Beitrag: 28.04.2010, 17:53
  4. SubDomain HTTPS Weiterleitung
    Von juhuuuu im Forum Fragen und Entscheidungshilfen zu den Resellerfunktionen
    Antworten: 1
    Letzter Beitrag: 06.07.2001, 12:23

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •